$re = '/^[^\d]+|[^\d]+$/';
$str = 'foo bar 2022 Nov 22nd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);