use strict;
my $str = 'Examples of URL patterns (cross linking the AEVA forum) that need conversion
============================================================================
Thread ID: 756
http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW=
Thread ID: 1667
http://www.aeva.asn.au/forums/forum_posts.asp?TID=270
Thread ID: 1959
http://www.aeva.asn.au/forums/forum_posts.asp?TID=316&PID=1958#1958
Thread ID: 1427
http://www.aeva.asn.au/forums/forum_posts.asp?TID=65&KW=&PID=646#646
Thread ID: 1997
http://www.aeva.asn.au/forums/forum_posts.asp?TID=161&PN=1
Thread ID:
Thread ID:
Thread ID:
Thread ID:
Thread ID:
Thread ID:
Probably ignore these patterns, not many of them...
===================================================
Thread ID: 8573
<img src="http://www.aeva.asn.au/forums/smileys/smiley4.gif" border="0" />
Thread ID: 4845
http://www.aeva.asn.au/forums/smileys/smiley18.gif
Hi Andrew,
<br />I cant for the life of me see how to PM. Is it enabled?
<br />
<br />Anyway, here are the conversations I started that could be re-clasified if you get a chance.
<br />
<br />Cheers,
<br />Mal.
<br />
<br />Media
<br />
<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=143&KW=
<br />
<br />
<br />Parts and Suppliers
<br />
<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW=
<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=128&KW=
<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=113&KW=
<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=116&KW=';
my $regex = qr/(?P<url>https?://(?:(?:www|forums)\.aeva\.asn\.au/forums|forums\.aeva\.asn\.au)[^\s\"<]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}