#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)))*$"
Local $sString = "1|order=asc|type=1" & @CRLF & _
"1" & @CRLF & _
"1|order=asc|type=1" & @CRLF & _
"1|type=1|order=asc" & @CRLF & _
"1|type=1|type=2|order=asc" & @CRLF & _
"" & @CRLF & _
"1|num=34|type=1|type=2|order=asc|num=14|status=done"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")