$re = '/\[metaslider\sid=\d+]/m';
$str = 'э[metaslider id=57]вфывфывфывфывфывфывф ыфвфыв ывфы вф sdasdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);