re = /\[metaslider\sid=\d+]/m
str = 'э[metaslider id=57]вфывфывфывфывфывфывф ыфвфыв ывфы вф sdasdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end