#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:(Jan(?:uary)?)|(Feb(?:ruary)?)|(Mar(?:ch)?)|(Apr(?:il)?)|(May)|(June?)|(July?)|(Aug(?:ust)?)|(Sept(?:ember)?)|(Oct(?:ober)?)|(Nov(?:ember)?)|(Dec(?:ember)?))\s+(?:(\d{2})|(\d))\s+(\d{4})"
Local $sString = "created: October 4 1984 22:01 test"
Local $sSubst = "$15-${1:+01}${2:+02}${3:+03}${4:+04}${5:+05}${6:+06}${7:+07}${8:+08}${9:+09}${10:+10}${11:+11}${12:+12}-${13:+$13:0$14}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)