# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(Jan(?:uary)?)|(Feb(?:ruary)?)|(Mar(?:ch)?)|(Apr(?:il)?)|(May)|(June?)|(July?)|(Aug(?:ust)?)|(Sept(?:ember)?)|(Oct(?:ober)?)|(Nov(?:ember)?)|(Dec(?:ember)?))\s+(?:(\d{2})|(\d))\s+(\d{4})"
test_str = "created: October 4 1984 22:01 test"
subst = "$15-${1:+01}${2:+02}${3:+03}${4:+04}${5:+05}${6:+06}${7:+07}${8:+08}${9:+09}${10:+10}${11:+11}${12:+12}-${13:+$13:0$14}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.