package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\||^)(\w+)=`)
var str = `TType=SEND|Status=OK|URL=min://j?_a=3&ver=1.1|day=3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}