#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?)(@)(\s.*)"
Local $sString = "DECLARE @showBrand@ VARCHAR(MAX) = '1';" & @CRLF & _
"DECLARE @showBrandImage@ VARCHAR(MAX) = '[]';" & @CRLF & _
"DECLARE @ShowBrandLink@ VARCHAR(MAX) = '[]';" & @CRLF & _
"DECLARE @ShowbreakLineAfterSize@ VARCHAR(MAX) = '[]';" & @CRLF & _
"DECLARE @showbreaklineAfterStock@ VARCHAR(MAX) = '[]';" & @CRLF & _
"DECLARE @showBuyBtn@ VARCHAR(MAX) = '1';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")