import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(@)(\\s.*)";
final String string = "DECLARE @showBrand@ VARCHAR(MAX) = '1';\n"
+ "DECLARE @showBrandImage@ VARCHAR(MAX) = '[]';\n"
+ "DECLARE @ShowBrandLink@ VARCHAR(MAX) = '[]';\n"
+ "DECLARE @ShowbreakLineAfterSize@ VARCHAR(MAX) = '[]';\n"
+ "DECLARE @showbreaklineAfterStock@ VARCHAR(MAX) = '[]';\n"
+ "DECLARE @showBuyBtn@ VARCHAR(MAX) = '1';";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}