package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\\W_]+\.)+$`)
var str = `string.string.
string.str_ing.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}