$re = '/^([^\\\\W_]+\.)+$/m';
$str = 'string.string.
string.str_ing.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);