$re = '/^(?P<descr>\S+(?:\s\S+)*)/m';
$str = 'HOSE 1/4 X BSP F 3/8 Each';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);