package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[.vhd]{4}$`)
var str = `testdir1\\testdir1\\textfile.vhd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}