$re = '/[.vhd]{4}$/';
$str = 'testdir1\\\\testdir1\\\\textfile.vhd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);