#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\+\-]+[\r\n](\|(\s+<info>[^<]+<\/info>\s+\|)+)[\r\n](\+|\-)+[\r\n]((\|(\s+[^\|]+\s+\|)+[\r\n])+)(\+|\-)+"
Local $sString = "+--------+------+-------+" & @CRLF & _
"| <info>number</info> | <info>char</info> | <info>word</info> |" & @CRLF & _
"+--------+------+-------+" & @CRLF & _
"| 1 | a | alfa |" & @CRLF & _
"| 2 | b | beta |" & @CRLF & _
"| 3 | c | gamma |" & @CRLF & _
"+--------+------+-------+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")