const regex = /[\+\-]+[\r\n](\|(\s+<info>[^<]+<\/info>\s+\|)+)[\r\n](\+|\-)+[\r\n]((\|(\s+[^\|]+\s+\|)+[\r\n])+)(\+|\-)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\+\\-]+[\\r\\n](\\|(\\s+<info>[^<]+<\\\/info>\\s+\\|)+)[\\r\\n](\\+|\\-)+[\\r\\n]((\\|(\\s+[^\\|]+\\s+\\|)+[\\r\\n])+)(\\+|\\-)+', 'gm')
const str = `+--------+------+-------+
| <info>number</info> | <info>char</info> | <info>word</info> |
+--------+------+-------+
| 1 | a | alfa |
| 2 | b | beta |
| 3 | c | gamma |
+--------+------+-------+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}