use strict;
my $str = 'Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd (Ft Young Joc) - Get It Shawty.mp3
Lloyd - Get It Shawty.mp3';
my $regex = qr/^([^-]+)-([^(]*) \((Ft[^)]*)\)(.*)$/mp;
my $subst = '$1$3 -$2$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";