re = /^([^-]+)-([^(]*) \((Ft[^)]*)\)(.*)$/m
str = 'Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd (Ft Young Joc) - Get It Shawty.mp3
Lloyd - Get It Shawty.mp3'
subst = '$1$3 -$2$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result