const regex = /\d{2}\-\w{3}\-\d{4}\s\d{2}\:\d{2}\:\d{2}\.\d{2}\s(?P<src_channel>\w+)\s+(?P<dst_channel>\w*)\s(?P<code>\w+)\s(?P<bytes>\d+)\s(?P<from>\w.+)\srfc822/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}\\-\\w{3}\\-\\d{4}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\.\\d{2}\\s(?P<src_channel>\\w+)\\s+(?P<dst_channel>\\w*)\\s(?P<code>\\w+)\\s(?P<bytes>\\d+)\\s(?P<from>\\w.+)\\srfc822', 'g')
const str = `02-Feb-2017 09:00:01.59 tcp_imap_int Q 12 xxx@xyz.com rfc822;user@imap-internal.xyz.com user@imap.xyz.com <6940401380880269855036@PT-D69> pmdf user@imap.xyz.com: smtp;452 4.2.2 Over quota`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}