# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<str_lit>(?P<begin_quote>(?P<single_quote>')|\")(?:(?(single_quote)\"|')|\\[\"']|\\[^\r\n ]|[^\"'\\\r\n])*?(?P=begin_quote))$"
test_str = ("\"double-quoted string\"\n"
"'single-quoted string'\n"
"\"unexpected EOL\n"
"'unexpected EOL\n"
"\"unclosed backslash escape: \\\"\n"
"\"properly doubled backslash: \\\\\"\n"
"\"escaped ' quotes and backslash escapes \\' are \\\" \\n allowed\"\n"
"\"\\t\\tindented code\\r\\n\"\n"
"\"invalid escape \\%\"\n"
"\"'\"\n"
"\"space is not a valid backslash escape: \\ \"\n"
"\"or newline either: \\\n"
"\"hopefully there aren't any edge-cases I didn't think of\"\n"
"\"\"\"oh, and single-line docstrings count as three string literals, so you would have to repeat the same expression multiple times to match it\"\"\"\n"
"\"\"\"and multi-line docstrings won't match even if you repeat the expression multiple times")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.