$re = '/(?<=^|[^_])__((?![\s_])(([^_]|_(?!_))+?)?[^\s_])__(?=[^_]|$)/m';
$str = '-- funciona
__foo bar__
__f o o b a r__
**teste __lorem ipsum__ dolor sit**
__teste **lorem ipsum** dolor sit__
abc__xyz__teste
-- não funcionava na primeira versão
__foo_bar__
__a__
__*__
__foo_*bar__
-- não é para funcionar
__ foo bar__
__foo bar __
_foo__
__ foo __
_foo_
__foo_
__ __
__a____
____a__
_____
-- corner case: aninhado (não tratei pois não sei o que deveria fazer)
__abc__xyz__123__
__abc __xyz__ 123__
';
$subst = "<i>\1<\i>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;