#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\b:?A)?(?:\b:?B)?(?:\b:?C)?(?:\b:?D)?$"
Local $sString = "These should all match:" & @CRLF & _
"" & @CRLF & _
"A" & @CRLF & _
"B" & @CRLF & _
"C" & @CRLF & _
"D" & @CRLF & _
"A:B" & @CRLF & _
"A:C" & @CRLF & _
"A:D" & @CRLF & _
"B:C" & @CRLF & _
"B:D" & @CRLF & _
"C:D" & @CRLF & _
"A:B:C" & @CRLF & _
"A:B:D" & @CRLF & _
"A:C:D" & @CRLF & _
"B:C:D" & @CRLF & _
"A:B:C:D" & @CRLF & _
"" & @CRLF & _
"Meanwhile, these should not match." & @CRLF & _
"" & @CRLF & _
"A:" & @CRLF & _
":C" & @CRLF & _
"ABC" & @CRLF & _
"A:BC" & @CRLF & _
"A::B" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")