const regex = /^(?:\b:?A)?(?:\b:?B)?(?:\b:?C)?(?:\b:?D)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\b:?A)?(?:\\b:?B)?(?:\\b:?C)?(?:\\b:?D)?$', 'gm')
const str = `These should all match:
A
B
C
D
A:B
A:C
A:D
B:C
B:D
C:D
A:B:C
A:B:D
A:C:D
B:C:D
A:B:C:D
Meanwhile, these should not match.
A:
:C
ABC
A:BC
A::B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}