import re
regex = re.compile(r"^([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])")
test_str = ("ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"abcdefghijklmnopqrstuvwxyz\n"
"0123456789\n"
"This is a pen.\n")
subst = "\"$1\"|"
result = regex.sub(subst, test_str)
if result:
print(result)