// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])").unwrap();
let string = "ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
0123456789
This is a pen.
";
let substitution = "\"$1\"|";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}