#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<img\s)(?![^>]*alt=)([^>]*>)"
Local $sString = "<img src="some-image.png" /> <img src="another-image.png" alt="Some text" /> " & @CRLF & _
"" & @CRLF & _
"<img src="another-image.png" alt="Some text" />" & @CRLF & _
"" & @CRLF & _
"<img src="some-image.png" />" & @CRLF & _
"" & @CRLF & _
" <img alt="Some text" src="another-image.png" />" & @CRLF & _
"" & @CRLF & _
"<img alt="Some text" src="another-image.png" /> <img src="some-image.png" />" & @CRLF & _
"" & @CRLF & _
"<img src="another-image.png" alt="Some text" /> <img src="some-image.png" /> <img src="some-image.png" />" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")