$re = '/(<img\s)(?![^>]*alt=)([^>]*>)/m';
$str = '<img src="some-image.png" /> <img src="another-image.png" alt="Some text" />
<img src="another-image.png" alt="Some text" />
<img src="some-image.png" />
<img alt="Some text" src="another-image.png" />
<img alt="Some text" src="another-image.png" /> <img src="some-image.png" />
<img src="another-image.png" alt="Some text" /> <img src="some-image.png" /> <img src="some-image.png" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);