#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?s)Query #.*?(?:(?:Alignments)|\Z)"
Local $sString = "Query #1: 020.1-Bni_its1_2019_envio1set1 Query ID: lcl|Query_25247 Length: 286" & @CRLF & _
"" & @CRLF & _
"Sequences producing significant alignments:" & @CRLF & _
" Scientific Common Max Total query E Per. Acc. " & @CRLF & _
"Description Name Name Taxid Score Score cover Value Ident Len Accession " & @CRLF & _
"Manihot esculenta mitochondrion, complete genome Manihot escu... cassava 3983 182 182 53% 2e-41 88.46 682840 NC_045136.1 " & @CRLF & _
"Manihot esculenta mitochondrion, complete genome Manihot escu... cassava 3983 182 182 53% 2e-41 88.46 682840 MK176513.1 " & @CRLF & _
"Asparagus officinalis cultivar Atlas mitochondrion, complete... Asparagus of... garden aspar... 4686 124 124 26% 4e-24 96.05 492062 NC_053642.1 " & @CRLF & _
"Capsicum annuum var. glabriusculum bio-material USDA:PI 593546... Capsicum ann... NA 165789 89.8 149 27% 1e-13 100.00 497487 MN196478.1 " & @CRLF & _
"Capsicum annuum cultivar Jeju mitochondrion, complete genome Capsicum annuum NA 4072 89.8 149 27% 1e-13 100.00 511530 KJ865410.1 " & @CRLF & _
"Capsicum annuum cultivar CMS line FS4401 mitochondrion, comple... Capsicum annuum NA 4072 89.8 149 27% 1e-13 100.00 507452 KJ865409.1 " & @CRLF & _
"Capsicum annuum clone CaSSR_42 microsatellite sequence Capsicum annuum NA 4072 89.8 89.8 17% 1e-13 98.04 668 KF824256.1 " & @CRLF & _
"mitochondrion genome of Capsicum chinense chromosome 1, comple... Capsicum chi... NA 80379 89.8 149 29% 1e-13 98.04 307629 MZ736638.1 " & @CRLF & _
"Dolichandrone spathacea chromosome DS1 mitochondrion, complete... Dolichandron... NA 241844 71.3 71.3 14% 5e-08 97.56 610698 MW432179.1 " & @CRLF & _
"Dolichandrone cauda-felina mitochondrion, complete genome Markhamia ca... NA 2871431 71.3 71.3 14% 5e-08 97.56 837447 MW432178.1 " & @CRLF & _
"Haematoxylum brasiletto mitochondrion, complete genome Haematoxylum... NA 191923 60.2 60.2 11% 1e-04 100.00 631094 NC_045040.1 " & @CRLF & _
"Haematoxylum brasiletto mitochondrion, complete genome Haematoxylum... NA 191923 60.2 60.2 11% 1e-04 100.00 631094 MN017229.1 " & @CRLF & _
"Leucaena trichandra mitochondrion, complete genome Leucaena tri... NA 190760 60.2 60.2 11% 1e-04 100.00 722009 NC_039738.1 " & @CRLF & _
"Leucaena trichandra mitochondrion, complete genome Leucaena tri... NA 190760 60.2 60.2 11% 1e-04 100.00 722009 MH717173.1 " & @CRLF & _
"Gleditsia sinensis mitochondrion, complete genome Gleditsia si... NA 66096 60.2 60.2 11% 1e-04 100.00 594121 MT921986.1 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Alignments:" & @CRLF & _
"" & @CRLF & _
">Manihot esculenta mitochondrion, complete genome" & @CRLF & _
"Sequence ID: NC_045136.1 Length: 682840" & @CRLF & _
"Range 1: 329883 to 330034" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")