re = /(?s)Query #.*?(?:(?:Alignments)|\Z)/
str = 'Query #1: 020.1-Bni_its1_2019_envio1set1 Query ID: lcl|Query_25247 Length: 286
Sequences producing significant alignments:
Scientific Common Max Total query E Per. Acc.
Description Name Name Taxid Score Score cover Value Ident Len Accession
Manihot esculenta mitochondrion, complete genome Manihot escu... cassava 3983 182 182 53% 2e-41 88.46 682840 NC_045136.1
Manihot esculenta mitochondrion, complete genome Manihot escu... cassava 3983 182 182 53% 2e-41 88.46 682840 MK176513.1
Asparagus officinalis cultivar Atlas mitochondrion, complete... Asparagus of... garden aspar... 4686 124 124 26% 4e-24 96.05 492062 NC_053642.1
Capsicum annuum var. glabriusculum bio-material USDA:PI 593546... Capsicum ann... NA 165789 89.8 149 27% 1e-13 100.00 497487 MN196478.1
Capsicum annuum cultivar Jeju mitochondrion, complete genome Capsicum annuum NA 4072 89.8 149 27% 1e-13 100.00 511530 KJ865410.1
Capsicum annuum cultivar CMS line FS4401 mitochondrion, comple... Capsicum annuum NA 4072 89.8 149 27% 1e-13 100.00 507452 KJ865409.1
Capsicum annuum clone CaSSR_42 microsatellite sequence Capsicum annuum NA 4072 89.8 89.8 17% 1e-13 98.04 668 KF824256.1
mitochondrion genome of Capsicum chinense chromosome 1, comple... Capsicum chi... NA 80379 89.8 149 29% 1e-13 98.04 307629 MZ736638.1
Dolichandrone spathacea chromosome DS1 mitochondrion, complete... Dolichandron... NA 241844 71.3 71.3 14% 5e-08 97.56 610698 MW432179.1
Dolichandrone cauda-felina mitochondrion, complete genome Markhamia ca... NA 2871431 71.3 71.3 14% 5e-08 97.56 837447 MW432178.1
Haematoxylum brasiletto mitochondrion, complete genome Haematoxylum... NA 191923 60.2 60.2 11% 1e-04 100.00 631094 NC_045040.1
Haematoxylum brasiletto mitochondrion, complete genome Haematoxylum... NA 191923 60.2 60.2 11% 1e-04 100.00 631094 MN017229.1
Leucaena trichandra mitochondrion, complete genome Leucaena tri... NA 190760 60.2 60.2 11% 1e-04 100.00 722009 NC_039738.1
Leucaena trichandra mitochondrion, complete genome Leucaena tri... NA 190760 60.2 60.2 11% 1e-04 100.00 722009 MH717173.1
Gleditsia sinensis mitochondrion, complete genome Gleditsia si... NA 66096 60.2 60.2 11% 1e-04 100.00 594121 MT921986.1
Alignments:
>Manihot esculenta mitochondrion, complete genome
Sequence ID: NC_045136.1 Length: 682840
Range 1: 329883 to 330034
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end