# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http(?:s|):\/\/(?:www\.|)example\.com\/)([^\/]+)\/(season-[0-9]{1,}|)((.+)\.html)"
test_str = ("https://example.com/serial/season-2/episode-3.html\n"
"https://example.com/serial/episode-1.html\n"
"http://example.com/serial/season-21/episode-3.html\n"
"http://example.com/serial/episode-1.html\n"
"https://www.example.com/serial/season-233/episode-3.html\n"
"https://www.example.com/serial/episode-21.html\n\n\n\n"
"как-то так\n"
"Так же в регулярку добавил варианты протоколов и с www\n"
"Ну и вам будет нужно то\n"
"$1 -название сериала\n"
"$2 эпизод если он есть\n"
"$3 эпизод без хтмл\n"
"$4 Эпизод с .html\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.