#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(node_modules\/(?!is-online|public-ip)|bower_components)"
Local $sString = "./node_modules/" & @CRLF & _
"./node_modules//" & @CRLF & _
"./node_modules/random-module" & @CRLF & _
"./node_modules//random-module" & @CRLF & _
"./node_modules/is-online" & @CRLF & _
"./node_modules//is-online" & @CRLF & _
"./node_modules/is-online/foo" & @CRLF & _
"./node_modules//public-ip" & @CRLF & _
"./node_modules/public-ip" & @CRLF & _
"./node_modules/public-ip/bar" & @CRLF & _
"./node_modules/is-online/public-ip" & @CRLF & _
"./node_modules/is-online/public-ip/" & @CRLF & _
"./bower_components" & @CRLF & _
"./bower_components/is-online" & @CRLF & _
"./bower_components/public-ip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")