const regex = /(node_modules\/(?!is-online|public-ip)|bower_components)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(node_modules\\\/(?!is-online|public-ip)|bower_components)', 'mg')
const str = `./node_modules/
./node_modules//
./node_modules/random-module
./node_modules//random-module
./node_modules/is-online
./node_modules//is-online
./node_modules/is-online/foo
./node_modules//public-ip
./node_modules/public-ip
./node_modules/public-ip/bar
./node_modules/is-online/public-ip
./node_modules/is-online/public-ip/
./bower_components
./bower_components/is-online
./bower_components/public-ip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}