#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)inclusion\s*:\s*(.+?)exclusion\s*:\s*(.+)"
Local $sString = "inclusion : ajjsdijd" & @CRLF & _
"sdsjdjs" & @CRLF & _
"ieroeito trorg inclusion" & @CRLF & _
"sdkjwedk" & @CRLF & _
"" & @CRLF & _
"exclusion :" & @CRLF & _
"sdkjwdowek" & @CRLF & _
" ksdldk exclusion" & @CRLF & _
"skdkefk" & @CRLF & _
"kfkwkfwe "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")