package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)inclusion\s*:\s*(.+?)exclusion\s*:\s*(.+)`)
var str = `inclusion : ajjsdijd
sdsjdjs
ieroeito trorg inclusion
sdkjwedk
exclusion :
sdkjwdowek
ksdldk exclusion
skdkefk
kfkwkfwe `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}