#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<meta (?:name|http-equiv)='(.*)' content='(.*)'>"
Local $sString = "<meta charset='UTF-8'>" & @CRLF & _
"<meta name='keywords' content='your, tags'>" & @CRLF & _
"<meta name='description' content='150 words'>" & @CRLF & _
"<meta name='subject' content='your website's subject'>" & @CRLF & _
"<meta name='copyright' content='company name'>" & @CRLF & _
"<meta name='language' content='ES'>" & @CRLF & _
"<meta name='robots' content='index,follow'>" & @CRLF & _
"<meta name='revised' content='Sunday, July 18th, 2010, 5:15 pm'>" & @CRLF & _
"<meta name='abstract' content=''>" & @CRLF & _
"<meta name='topic' content=''>" & @CRLF & _
"<meta name='summary' content=''>" & @CRLF & _
"<meta name='Classification' content='Business'>" & @CRLF & _
"<meta name='author' content='name, email@hotmail.com'>" & @CRLF & _
"<meta name='designer' content=''>" & @CRLF & _
"<meta name='reply-to' content='email@hotmail.com'>" & @CRLF & _
"<meta name='owner' content=''>" & @CRLF & _
"<meta name='url' content='http://www.websiteaddrress.com'>" & @CRLF & _
"<meta name='identifier-URL' content='http://www.websiteaddress.com'>" & @CRLF & _
"<meta name='directory' content='submission'>" & @CRLF & _
"<meta name='pagename' content='jQuery Tools, Tutorials and Resources - O'Reilly Media'>" & @CRLF & _
"<meta name='category' content=''>" & @CRLF & _
"<meta name='coverage' content='Worldwide'>" & @CRLF & _
"<meta name='distribution' content='Global'>" & @CRLF & _
"<meta name='rating' content='General'>" & @CRLF & _
"<meta name='revisit-after' content='7 days'>" & @CRLF & _
"<meta name='subtitle' content='This is my subtitle'>" & @CRLF & _
"<meta name='target' content='all'>" & @CRLF & _
"<meta name='HandheldFriendly' content='True'>" & @CRLF & _
"<meta name='MobileOptimized' content='320'>" & @CRLF & _
"<meta name='date' content='Sep. 27, 2010'>" & @CRLF & _
"<meta name='search_date' content='2010-09-27'>" & @CRLF & _
"<meta name='DC.title' content='Unstoppable Robot Ninja'>" & @CRLF & _
"<meta name='ResourceLoaderDynamicStyles' content=''>" & @CRLF & _
"<meta name='medium' content='blog'>" & @CRLF & _
"<meta name='syndication-source' content='https://mashable.com/2008/12/24/free-brand-monitoring-tools/'>" & @CRLF & _
"<meta name='original-source' content='https://mashable.com/2008/12/24/free-brand-monitoring-tools/'>" & @CRLF & _
"<meta name='verify-v1' content='dV1r/ZJJdDEI++fKJ6iDEl6o+TMNtSu0kv18ONeqM0I='>" & @CRLF & _
"<meta name='y_key' content='1e39c508e0d87750'>" & @CRLF & _
"<meta name='pageKey' content='guest-home'>" & @CRLF & _
"<meta itemprop='name' content='jQTouch'>" & @CRLF & _
"<meta http-equiv='Expires' content='0'>" & @CRLF & _
"<meta http-equiv='Pragma' content='no-cache'>" & @CRLF & _
"<meta http-equiv='Cache-Control' content='no-cache'>" & @CRLF & _
"<meta http-equiv='imagetoolbar' content='no'>" & @CRLF & _
"<meta http-equiv='x-dns-prefetch-control' content='off'>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")