use strict;
my $str = '<meta charset=\'UTF-8\'>
<meta name=\'keywords\' content=\'your, tags\'>
<meta name=\'description\' content=\'150 words\'>
<meta name=\'subject\' content=\'your website\'s subject\'>
<meta name=\'copyright\' content=\'company name\'>
<meta name=\'language\' content=\'ES\'>
<meta name=\'robots\' content=\'index,follow\'>
<meta name=\'revised\' content=\'Sunday, July 18th, 2010, 5:15 pm\'>
<meta name=\'abstract\' content=\'\'>
<meta name=\'topic\' content=\'\'>
<meta name=\'summary\' content=\'\'>
<meta name=\'Classification\' content=\'Business\'>
<meta name=\'author\' content=\'name, email@hotmail.com\'>
<meta name=\'designer\' content=\'\'>
<meta name=\'reply-to\' content=\'email@hotmail.com\'>
<meta name=\'owner\' content=\'\'>
<meta name=\'url\' content=\'http://www.websiteaddrress.com\'>
<meta name=\'identifier-URL\' content=\'http://www.websiteaddress.com\'>
<meta name=\'directory\' content=\'submission\'>
<meta name=\'pagename\' content=\'jQuery Tools, Tutorials and Resources - O\'Reilly Media\'>
<meta name=\'category\' content=\'\'>
<meta name=\'coverage\' content=\'Worldwide\'>
<meta name=\'distribution\' content=\'Global\'>
<meta name=\'rating\' content=\'General\'>
<meta name=\'revisit-after\' content=\'7 days\'>
<meta name=\'subtitle\' content=\'This is my subtitle\'>
<meta name=\'target\' content=\'all\'>
<meta name=\'HandheldFriendly\' content=\'True\'>
<meta name=\'MobileOptimized\' content=\'320\'>
<meta name=\'date\' content=\'Sep. 27, 2010\'>
<meta name=\'search_date\' content=\'2010-09-27\'>
<meta name=\'DC.title\' content=\'Unstoppable Robot Ninja\'>
<meta name=\'ResourceLoaderDynamicStyles\' content=\'\'>
<meta name=\'medium\' content=\'blog\'>
<meta name=\'syndication-source\' content=\'https://mashable.com/2008/12/24/free-brand-monitoring-tools/\'>
<meta name=\'original-source\' content=\'https://mashable.com/2008/12/24/free-brand-monitoring-tools/\'>
<meta name=\'verify-v1\' content=\'dV1r/ZJJdDEI++fKJ6iDEl6o+TMNtSu0kv18ONeqM0I=\'>
<meta name=\'y_key\' content=\'1e39c508e0d87750\'>
<meta name=\'pageKey\' content=\'guest-home\'>
<meta itemprop=\'name\' content=\'jQTouch\'>
<meta http-equiv=\'Expires\' content=\'0\'>
<meta http-equiv=\'Pragma\' content=\'no-cache\'>
<meta http-equiv=\'Cache-Control\' content=\'no-cache\'>
<meta http-equiv=\'imagetoolbar\' content=\'no\'>
<meta http-equiv=\'x-dns-prefetch-control\' content=\'off\'>';
my $regex = qr/<meta (?:name|http-equiv)='(.*)' content='(.*)'>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}