$re = '/^\[(.*?)\s>\s(.*)\]\s(.*):\s(.*)$/m';
$str = '["Course_title" > "directory_1 > directory_2"] "forum": "title"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);