re = /^\[(.*?)\s>\s(.*)\]\s(.*):\s(.*)$/m
str = '["Course_title" > "directory_1 > directory_2"] "forum": "title"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end