package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\?{3}\h+ad-question\h+(.+)\n+((?:.*\n?)+?)\n+^---\h+admonition$`)
var str = `??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}