// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\?{3}\h+ad-question\h+(.+)\n+((?:.*\n?)+?)\n+^---\h+admonition$").unwrap();
let string = "??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}