re = /^http(?:s)?:\/\/(?:www\.)?(?:[\w-]+?\.)?reddit.com(\/r\/|\/user\/)?(?(1)([\w:]{2,21}))(\/comments\/)?(?(3)(\w{5,6})(?:\/[\w%\\\\-]+)?)?(?(4)\/(\w{7}))?\/?(\?)?(?(6)(\S+))?(\#)?(?(8)(\S+))?$/m
str = 'https://www.reddit.com/r/WTF/comments/17j3sd/this_crawled_into_one_of_my_students_pool_and_she/c867wpi/#c867wpi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end