package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[A-Z ]{3,}-\d{1,6}$`)
var str = `Some Text-1
Some Text-201901
Some Text-20190101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}