$re = '/^[A-Z ]{3,}-\d{1,6}$/mi';
$str = 'Some Text-1
Some Text-201901
Some Text-20190101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);