using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(.*(?:[ -\/:-@[-`{-~À-ÿ].*){4}))^[A-Za-z\d -\/:-@[-`{-~À-ÿ]{8,30}$";
string input = @"AABBCCDD
OK -- Match
aabbccdd
OK -- Match
11111111
OK -- Match
A1A1b2b2
OK -- Match
A@~D1dIo
OK -- Match
AAB BCC0
OK -- Match (1 special, it's okay)
AABBCC@@
OK -- Match (2 specials, it's okay)
AABB C
OK -- Match (3 specials, it's okay)
A@~` C:
OK -- Match (3 specials, it's okay)
AABB
OK -- Should't match and didn't match (Less than 8 symbols)
AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPP
OK -- Should't match and didn't match (More than 30 symbols)
AA@@@@BB
ERROR ! -- Shouldn't match (4 specials, it's forbidden)
AAB B
ERROR ! -- Shouldn't match (4 specials, it's forbidden)
AABB@@@@
ERROR ! -- Shouldn't match (4 specials, it's forbidden)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}