use strict;
my $str = 'AABBCCDD
OK -- Match
aabbccdd
OK -- Match
11111111
OK -- Match
A1A1b2b2
OK -- Match
A@~D1dIo
OK -- Match
AAB BCC0
OK -- Match (1 special, it\'s okay)
AABBCC@@
OK -- Match (2 specials, it\'s okay)
AABB C
OK -- Match (3 specials, it\'s okay)
A@~` C:
OK -- Match (3 specials, it\'s okay)
AABB
OK -- Should\'t match and didn\'t match (Less than 8 symbols)
AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPP
OK -- Should\'t match and didn\'t match (More than 30 symbols)
AA@@@@BB
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
AAB B
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
AABB@@@@
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
';
my $regex = qr/(?!(.*(?:[ -\/:-@[-`{-~À-ÿ].*){4}))^[A-Za-z\d -\/:-@[-`{-~À-ÿ]{8,30}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}