package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(www\.)?(\S+(\.\S+)?)`)
var str = `www.neco
wtf.tamto
www.www.hento`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}