$re = '/(www\.)?(\S+(\.\S+)?)/m';
$str = 'www.neco
wtf.tamto
www.www.hento';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);