re = /([?&])ordem=\d+(?:&|$)/m
str = 'http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result