package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0+|(?:\.|(\..*?))0+$`)
var str = `00100.2300
00100
00100.0023
100.00`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}